For those with ATI video cards...

Please search for answers and post about your technical problems when running Full Ace here
Fresh Boarder
Fresh Boarder
Posts: 6
Joined: Fri Jul 31, 2009 7:30 am

For those with ATI video cards...

Postby Vicencio » Sat Aug 01, 2009 2:56 pm

If you have ATI video cards and are experiencing any problems, post your questions/concerns here.

When I first attempted to play the beta version of Full Ace, I wasn't successful right from the start. When I clicked "tutorial" in the main menu, the game would suddenly crash. I consulted this problem to kschoice and informed me that the problem lies within my ATI graphics card. He asked me my video card model and whether or not I have updated my video card driver recently. When I checked the video card properties, the driver version was somewhere around 8.1 released on 2006. So it has been quite some time. What I did is plain simple - I updated the video card drivers to the latest edition.

There are a lot of websites that offer driver downloads for free but not all of them offer the latest driver editions so I suggest that you just go to the ATI website. Here is the URL:

Download and Install the ENTIRE catalyst driver for your video card and make sure that the driver is compatible for your video card. For example, the latest catalyst release is 9.7 but the latest release compatible for my card is only 9.3. When you specify your ATI video card model, the website should automatically redirect you to the latest compatible driver for your video card.

I hope this helps those who use ATI video cards and are having problems running this wonderful game.

For those who have other issues or concerns with their ATI video cards, post them here and let's try to work it out.

Fresh Boarder
Fresh Boarder
Posts: 1
Joined: Wed Apr 21, 2010 3:37 pm

Re: For those with ATI video cards...

Postby beatrix » Wed Apr 21, 2010 3:48 pm


I just tried to play with an ATI RADEON HD 5700 and to make Full Ace working properly, I had to enable the option "Triple buffering" in ->3D parameters -> OpenGL parameters. Hope it could be useful for someone.

Return to “Full Ace troubleshooting”

Who is online

Users browsing this forum: No registered users and 12 guests